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1. Introduction

WELCOME!

Congratulations. If you are reading this manual, then you already have a successful multi-store operation or you are
on your way to bringing one online. With The Uniform Solution, you can be assured that your multi-store operation
will be as successful as you can possibly make it. The Uniform Solution brings unprecedented simplicity and power
to the independent retailer with multiple locations. Multiple physical locations are easy to set up and the program
will enable you to easily control your entire multi-store operation from one location if you wish.

What you'll find in this book.

This manual contains the information necessary to set up and configure The Uniform Solution in a multi-store
environment. The Uniform Solution offers two program versions, Cloud or Desktop. With The Uniform Solution
Cloud, there is no need to use the batching process because all store locations are already sharing their data in real
time while connected to the Cloud. Sales that occur at remote stores appear in the system as they are completed. And
updating your vendor catalogs is instantly applied to all locations on the Cloud. The Uniform Solution Cloud is the
easiest way to manage multiple uniform retail locations. This guide also contains an overview of the special multi-
store features and the daily activities required for the Desktop version of The Uniform Solution; including
conducting the Batch operation. For general information about The Uniform Solution and its normal operations,
you should refer to the QuickStart Guide.

Where to find more information.

The best place to find answers to questions regarding The Uniform Solution is right in the program itself. The online
Help system is specifically designed to be comprehensive and available at your fingertips. Whenever you would like
help on a particular section or screen, hit the F1 key to launch the internal Help system. For training, go to the Help >
Training Courses menu item, find the course you would like to watch, select Play, and a tutorial will walk you through
the topic you selected. You can also find more information on our website at www.theuniformsolution.com/support.

PRODUCT INFORMATION

Multi-Store Features

The Uniform Solution offers many features that continue to make it the best and easiest to use multi-store inventory
control package for Windows.

e Customers, contracts, inventory quantities, purchase orders, receiving/transfers lists, sales, special orders,
layaways, and quotes can be entered and maintained at each physical location.

e Any information created by any store can be shared with any other physical location.

e Purchase orders can be created for any store at any store. This feature enables a centralized purchase ordering
capability or the option to create purchase orders at each physical location. Purchase orders created for other
stores can be drop shipped and received at the remote location.

e Merchandise can be received from a purchase order at any location for any location.
e Transfers can be created for outgoing and incoming merchandise.

e Asingle location is responsible for maintaining items that remain consistent through all physical locations -
making inventory set up and other maintenance requirements easy and very productive.

e Each individual store can have its own retail pricing level (5 available).
e Reports can be run for one store or all stores to easily view performance or the needs of the entire operation.

e Data between physical locations is consolidated and distributed during a daily polling operation.


http://www.theuniformsolution.com/support

e  Only information changed during a batch period is sent during the polling operation - dramatically minimizing
the time it takes for the process to complete.

e The polling operation can be conducted by modem transfer or a network connection.

e A batch log records all polling activities.

DOCUMENTATION CONVENTIONS

Typeface Conventions

Italics Indicates what to type at the keyboard, such as £nter your store name here.

SMALL CAPS Indicates keystrokes to enter at the keyboard such as EnTER or F1 and
mouse operations such as RIGHT-CLICK.

Boldface Indicates commands or options from a menu. Using arrows indicates a
submenu. For example, selecting the Account Statements Report would
be written as Reports > Customers > Account Statements.

Keyboard Conventions

F1 Indicates a single keystroke. In this case, press and release the F1 key.
ALT+X Indicates a combination of keystrokes. In this case, hold down the ALT
OR key and press the X key, then release both keys. In the second example,
ALT+X, Y

hold down the ALT key, then press and release the X key, then press and
release the Y key.



2. Multi-Location Overview

INTRODUCTION

Since the cost of maintaining a Citrix or Windows Terminal Server can be cost prohibitive for some companies, The
Uniform Solution offers two program versions, Cloud or Desktop. The Desktop version can consolidate and
distribute data between locations once a day in a nightly polling operation that uses an inexpensive FTP site. The
polling operation runs each evening and only sends data that is new or has been changed by a location. At the start
of the day, each location will have information that was accurate at the close of the previous day for the other
locations. The Cloud version supports a live connection from each location to the same cloud server; this allows all
locations to see orders, and inventory changes as they happen in other locations.

Much of this guide will discuss the Desktop version, as mentioned previously, the Cloud version does not require the
setup for Batching.

You can find the information describing the Cloud version in blue text boxes like this one. Be
conscious that the Cloud version requires less steps because the batching process is not needed
with the Cloud version, and all stores are setup as Local locations (excluding Mobile stores).

TERMINOLOGY

The Polling Location

The polling location is the physical location that is usually the centerpiece of a multiple location operation. The
polling location is usually either the largest store in the retail operation, a warehouse for ordering and distributing
merchandise, or the corporate headquarters. It is the location determined to be the most central or the most
strategic to the entire retail operation, and it is the location where operations only allowed by one location are best
performed. The polling location is the location responsible for contacting each remote location in the nightly polling
operation.

Remote Locations (Locations that will be polled)

Remote locations are locations physically located away from the polling location. They are contacted nightly by the
polling location and send newly added or changed information.

The Batch Process

The Batch Process refers to the nightly polling operation conducted to consolidate and distribute data between the
polling location and the remote locations. The polling operation is conducted by using a phone line and modem to
connect the polling location with a remote location. Since the data being sent between locations contains only new
or changed information, the polling operation is very fast.

DUTIES OF THE POLLING LOCATION

Some information in The Uniform Solution can only be maintained (added or updated) at the polling location. New
inventory items, the user list, customer standards, and inventory standards, are a few examples of information
maintained at the polling location. Having this information maintained at the polling location simplifies the multi-
store operation and provides a form of centralized control over critical items.

A DETAILED EXPLANATION OF THE POLLING OPERATION

The polling operation in The Uniform Solution allows each remote location to share as much or as little data with
the polling location as you like. It also allows you to choose what data from what locations you would like to see.



Data Distribution

The polling location is the centerpiece of the data collection and distribution process. The polling location is
responsible for contacting remote locations to gather data then to give it back. The polling location simply collects
any information provided by a remote location.

Remote Locations

Remote locations are responsible for defining what information to send to the polling location and what information
to receive back from the polling location.

Local and Remote Stores

Each store defined in The Uniform Solution is assigned a unique store number. This store number is referenced at
both the polling and remote locations. A store referenced in the program is either a "Local" store or a "Remote” store
depending on the current physical location where the program is operating.

A "Local" store is a store that operates at the current physical location. A "Remote" store is a store that is at another
physical location. Both the polling location and a remote location will have "Local" and "Remote" stores. However,
the same store number can only be a "Local" store at only one location. New invoices, purchase orders, receiving lists,
customers, etc., can only be created for "Local" stores.

Batch Date

Each file that can be included in the data distribution process keeps track of the last date any record was updated.
When the Batch process is executed, only information that has changed during the Batch period is sent to the polling
location or to the remote location requesting information from other locations.

No Deletes

Every record used in the distribution process has a unique auto-numbered value that never changes. This unique
value makes it possible for the polling process to easily handle record updates and deletions. Deleting a record with
a unique value in the program does not actually delete the record, it simply updates a status field to indicate that the
record is deleted. When the status of a record is marked as deleted, any field in the record structure that is used for
other unique keys are blanked of their values - allowing the same record to be added in the future if needed.

Items deleted from a file are automatically removed 60 days after the deletion date during the month-end process.
Therefore, it is necessary to run the polling operation at least every 30 days to keep the information accurate at all
locations.

Ownership

Information specific to a store can only be entered and maintained (updated) when the store is "Local" to the physical
location. This means that if Store 2 created an invoice, only Store 2 can modify it, or deliver items from it. That is,
until ownership is transferred to another store at another location. During the polling operation, ownership of a
special order or invoice can be transferred to another store. Essentially, the newly assigned store has the ability to
perform the same operations with which only the "Local" store usually has available.

Log Files

Each physical location that has a "Local” store is the absolute keeper of the data created by the store. Other locations
may be allowed to perform activities that affect a "Remote" store's data, but records at a location where a store is
"Local" store are only updated using log files. Log Files are used as a means of controlling record updates. A major
principal behind the Batch process is that it is not possible to directly update records for a store "Remote” to the
current location. Each time an update to a remote store's information occurs, the actual record is updated on the
local system, and a log of the update is recorded. The log of the record update is sent to the location where the
record (i.e. the store) is "Local", and the transaction log is processed which actually performs the necessary updates to
the "Local" records.



Activities

Many of the activities in a multi-location environment are limited to being performed by either the polling location, or
the location that created a particular item. The table below provides a listing of the different activities and their
limitations. The item, "For a Local Store" can also mean where the owner is "Local".

At the Fora For Any
Activity Polling Local Store
Location | Store
Create and Modify Inventory Items (Styles and Products) X
Create and Modify Inventory and Customer Standards X

Create and Modify Alternate Sales Taxes and Tax Rules, Payment | X
Methods, Shipping Options, Users, and WebStore Configurations
and Content Pages

Create and Modify Invoices (Sales, Special Orders, Layaways, Gift X
Certificates, and Quotes)

Create and Modify Contracts

Create and Modify Payments for Invoices

Take a Physical Inventory

Update Accounts Payable

Create and Modify Purchase Orders

X | X| X| X| X| X

Create and Modify Receiving and Transfer Lists

Create and Modify Customers

X[ X | X| X

Update Inventory Quantities and Max/Min values

All features and activities are available at all locations with the Cloud version. You are able to
limit access based on the user login. This way you can prevent a clerk from modifying styles or
inventory counts in any (or all) of your retail locations. You the owner can have the user
permission to update and modify styles and inventory counts at all locations. If you work in one
store today and in another location tomorrow, your access and features will be the exact same
in each location based on your user account.




3. Getting Started

SETTING UP THE SOFTWARE AT EACH LOCATION

The multi-store version of The Uniform Solution runs on an independently maintained set of data at each physical
location. In order for the polling process to work properly, each physical location must be carefully configured. The
process is not difficult, but it must be accurately defined for proper operation.

Note: Once you have properly set up each physical location, you won't have to do it again, and the settings should
not be modified unless you talk with technical support.

Program Installation

For specific information about program installation, please refer to the QuickStart Guide. After installing and
registering the software, it is imperative that you immediately perform the following setup procedures.

m The Uniform Solution Cloud - Version 2022-6.60 T22 RC37 - Uniforms USA

File Home Activities Lists Maintenance Reports Setup Window

Dz /2 <0& m =

Computer Store System Polling Setup Data Mobile WebStore Coupons Payments
= Wizard Sharing API

Update Store Settings Connected Features

Store List

Define All Stores - Both Local and Remote

After installing the software, the first step is to define each store that is local to the physical location, and each store
that has information that this location would like to view. You must set up at least two stores (one local and one
remote). In most cases, if you have a total of 4 stores (both remote and local), you would setup 4 stores.

To add new stores, select Setup > Store > Add a New Store. While adding a new store, you will have the option set the
store number for the store you are adding. However, once a store's information has been saved, the only way to
change a store number is to delete the store, then add it back. Setting up the first store is important because each
subsequent store, which is added, uses the settings from the first store.

Once you have the polling location set up with all stores, the best way to set up a remote location is to take a backup
of the polling location data to the remote location where it will be restored. Once the backup is restored, the local
and remote stores must be updated and the new software license for the remote location must be registered.

With the Cloud version of The Uniform Solution, you just need to call our Support team to add
a store license and get assistance setting up your workstations at the new location. Once you
setup the workstations and the new store profile you are ready to start scanning in your
inventory counts. There is no need to mess with data backups or Polling settings on The
Uniform Solution Cloud.
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Define the Location Type - The Polling Location or a Location to be Polled

There are two types of potential locations in a multi-location environment: the polling location, and a location that
will be polled. There is only one polling location, but there may be many locations that will be polled.

To set the type of location, select Setup > Multi- # Multi-Location Poling (=N
Location Polling. Once you have set the location type, | 1 Gensral 2FTp setings
PBolling for Remote Locations oK

you need to set the available options. o vees =
If the location is the polling location, set the station ® This location will perform the palling operation and contact al remote locations
number that will perform the actual polling. The

other options may be left at their defaults.

Cancel
(O This location is a remote location that will be polled
Station to run the Baich update process 1| <

Batch Start Time

[] et a time to pegin the polling operation and go of-line

If the location will be polled, there are a number of

Batch Start Time:
options that can be set, but most items will be left at Reties
their default settings. The most important item is MaxRetrytampts: | 5% Retry Wait Time | 512

found on the Method Tab. The items on the Method L
Tab define how the location will be contacted. For
FTP connections, make sure the login name and
password you enter matches the setting for the
FTP server. For modem connections, make sure the

# Multi-Location Polling EI = \EI

1 General 2 Send 3. Method 4 Receivel 5 Receivell

. Contact Method OK

login name and password match the values for the —

R X . ) Modem ) Network @FTP: e
store at the polling location. Network connections
default to a standard transfer directory. For more e | |
information about selecting the information to Login Nz | |
send and receive, press F1 and use the on-line Password: | |
Help system. If you are unsure what to set, leave FTP Directory | |
the settings at their defaults FTP Port l:l 21is the standard FTP port number

: [JUse passive mode  [] Suppress directory errors

Complete Store Setup Reset

After defining the type of location, you can complete the setup by properly defining each store as either a "Local" or
"Remote" store and setting the options on the Options and Polling Tabs. A "Local" store is the store that operates at
the current physical location. A "Remote" store is a store that is at another physical location.

To complete the store setup process, select Setup > Stores and select each store for updating. On the General Tab, set
the type of store to either "Local" or "Remote".

If you are setting up the polling location, the Polling Tab for each remote store contains settings for the contact
method. For modem connections, the user name and password must match user name and password defined by
store at the remote location. For

. . . / Ch Store Setti Local Store # 1) - Applies to This Location Onl =
netWOrk COnneCtIOnS, the InCOmIng anging Store Settings (Local Store #1) pplies to This Location Only EI @
and Outgoing directories mUSt be the 1. Ceneral 2 Defaults 2 Messages 4 Pricing 5 Options § Web Server 7. Payments g Access

General Emails Texts

same "logical" directories defined by
the store at the remote location.

Inventary Options Cancel

[[]'This store does not maintain an individual inventory

Invoice Options
Create a separate order for special order items on a sale

The Options Tab has settings, which
must be carefully set for each store.
Press F1 for Help while on this tab for
information about each option.

Note: Purchase orders for special
orders for a store should not be
created at more than one
location. This could potentially

[] Transfer ownership of special orders to a remote location
[] Transfer ownership of sales invoices to a remote location

Auto Numbering Minimums

Invoices: 1,000 Purchase Orders: 1,000
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cause special orders to be placed onto more than one purchase order. The same is true for
ordering inventory below desired stock levels.

Set Up the Modem

The polling location always requires the modem to be properly configured for the Batch to start, and a remote
location requires the modem to be configured if it will be contacted by modem. To setup the modem for the Batch
process, select Setup > Modem from the application’'s main menu.

Always set the Modem to "Hayes Compatible (default), and make sure you set the proper COM port. Do not change
the settings on the other tabs unless instructed to do so. If the modem does not appear to function properly, try the
"Hayes Compatible (alternate)" option in the modem listing.

1. Modem Settings |2. tModem Commands |

Modem: [Hayes Compatible [default] =

C |
Fot  [COM1 [«] Baud Riate: (33400 [ -

Beset Defauls

|1k

Test Modem
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4. Running the Daily Batch Process

OVERVIEW

The Batch process is typically run once a day at the end of the day. The whole process is controlled by the polling
location, but the remote locations must be ready to be contacted by the polling location.

Remote locations enter the date range that will be transmitted to the polling location. That date range will also be
used by the polling location to determine what information is sent back to the remote location. The polling location
processes all information sent, and it sends back information that the remote location requested. Batches can be re-
run for the same date range if needed.

Once the Batch process is started, the polling location will need to make a total of four file transfers between each
remote location for the process to complete. Although the number of transfers may seem excessive, it is required to
handle the complexities of the distributed databases. The file transfers are also very fast since only information
changed during the batch dates is sent. The first file transfer sends a log of record modifications to the polling
location for any store "Remote” to the current location. Once all logs are received by the polling location, they are
distributed to each remote location and processed. The third file transfer is used to send records to the polling
location that are "Local" to the current location and have been updated within the Batch dates. The fourth file
transfer is to a remote location and includes any information requested by a remote location for stores "Remote" to
the current location.

When the Batch is complete, a message box will display a message noting the completion.

Batch Start Times

The Batch process must be started at the end of each day by selecting Activities > Daily Batch Update Process. At
remote locations, the process will begin after selecting the Start button and will wait for contact by the polling
location. At the polling location, the process will begin after selecting the Start button, but it will wait to start
contacting the remote locations if a wait time was specified in the Multi-Location Polling Setup screen. However,
once a Batch has been started but not completed, the Batch process will resume immediately after selecting Restart.

Failed Connections

If an attempt to connect to a remote location fails, the Batch Process will move on to the next location requiring
contact for the current step (if one exists), or it will wait the specified time to retry the current location. After a certain
number of failed contact attempts on a given step, the Batch process will "exclude" the problem location from the
process and continue with the other locations. Any location excluded from the current Batch can be re-run for the
failed dates the next time the Batch is run.

Resetting the Batch

Once a Batch is started, the program sets a status flag that helps ensure that the Batch is properly completed at both
a remote location and the polling location. Closing the Batch Update Process screen after a Batch has been started
will require you to either close the entire program or return to the Batch process screen. In order to be able to use
the program for normal activities, the Batch process must complete or manually reset by selecting the Reset button
on the Batch Update Process screen. Resetting the Batch causes the entire process to start over from the beginning.
There is no problem resetting a Batch in process, the Batch will just need to be re-run for the same days the next time
the Batch is executed.

Sending Changed Data or Complete Files

The Batch process normally only sends information changed during batch dates. This keeps transmission times very
small. However, there is an option to send a complete listing for selected files. This option is found on the Files Tab
of the Batch Update Process screen.
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At a remote location, you can send all customers and inventory quantities for any local store. At the polling location
you have the same options, plus the ability to send any information that is maintained by the polling location such as
inventory items, users, sales tax rates, etc. If you wish to send all sales information, just run a Batch for the desired
time-period. Just keep in mind, the more information you send, the longer the transmission will take.
The need to send complete file listings should be very limited. An example of when you would want to send
complete file listings from the polling location is for new locations coming on-line and running a Batch for the first

time.

RUNNING THE BATCH AT A REMOTE LOCATION

To start the Batch update process, select Activities
> Daily Batch Update Process from the application's
main menu. The batch start date defaults to the
day after the last successful batch date, and the
end date defaults to the current date. Normally
you will not change these dates. Select Start to
begin the Batch process.

RUNNING THE BATCH AT THE
POLLING LOCATION

I;I'j; Batch Update Process - Remote Location

1. Status 2. Files 3. Options

Last Completed Batch:

Current Batch

Start Date:

End Date: 12/10/23

Batch Status: Mot started

Perform a Drop Off Batch

lo | @ sl

« Start

Close

TestFTP
Batch Log

Reset

To start the Batch update process, select Activities > Daily Batch Update Process from the application's main menu.

Select Start to begin the Batch process.

Omitting a Store from the Current Batch

It is possible to exclude one or more stores from the current Batch process. Highlight a store in the list, right-click
and select Exclude. Stores excluded from the current Batch are not re-activated until you right-click and select Include.

Sending Entire Files to the Remotes

Select the File Tab, and check the files you would like to send as complete. If you are bringing a new remote location
on-line, you should check all the files so the remote location gets a complete copy of all the data maintained by the

central location.

I;I'_“; Batch Update Process - Polling Location

1. Status 2. Files 3. Options

Store MName
FPolling Location

002 | Traveling Sales

Method

Attempts Status
Batch Successful!

Data Upload Complete

Store W Status: Batch Successful!

lo] ® =]

+ Start

Close

TestFTP
Batch Log

Reset
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5. Special Multi-Store Features

SETTING THE CURRENT "LOCAL" STORE

If more than one "Local" store is defined at the current location, it is possible to create invoices for any of the "Local”
stores. Which store you are creating an invoice for is determined by the store selected in the application's toolbar.
To change the store, use the mouse and select the store you want.

E The Uniform Solution Cloud - Version 2022-6.60 T22 RC37 - Uniforms USA - X
File Home Activities Lists Maintenance Reports Setup Window Help Development
P — - == D qan
X 5 L
wa {2 EE i £ G & @
New Customers Orders Payment Contracts Texs tem PO Receive Tags Clock  WebStare Your
. . . . . . In/Out . Store
Customers tems Ecommerce Store

Application Toolbar - Local store selection

TRANSFERRING MERCHANDISE BETWEEN STORES

Creating an Inventory Transfer

The Enterprise version has the ability to transfer merchandise between any two stores. You can transfer merchandise
into a store, out of a store, or out of and into a store - the latter making adjustments to the inventories of both stores.
To create an inventory transfer, select Activities > Receiving/Transfers or select the Receive button from the toolbar.
Select the List button to add a new list. Set the type of list to a Transfer.

To add items to the transfer, simply scan the barcodes of the items you wish to transfer after setting the incoming and
outgoing stores. Select OK and, depending on the transfer type you selected, the items on the list will be subtracted
from inventory, added to inventory, or both.

Transferring Stock for Special Order Items

It is possible to transfer items from stock at one store to a particular special order line item - provided the special
order item requires fulfillment and the special order is viewable at the current location. When creating a new transfer,
set list type to Transfer Out and In. You can then use the F2-Add Spec button to select the special order items
needed by the store receiving the transfer. Transfers for special order items move the item out of stock
from sending store and into hold at the receiving store.
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6. Known Issues

OVERVIEW

From a data management perspective, the Batch Process is a very sophisticated and complex operation which
accurately distributes the information that is created and revised between locations. Overall, the polling operation is
simple and works exactly as you would expect - distributing changes and updates while receiving the information you
have selected. However, if you run an operation that creates Purchase Orders for Special Orders that were not
created (or "Owned") at the same physical location, there are certain scenarios that can produce invalid on order
quantities for a particular inventory item. Although a discrepancy can occur, the Month-End Process (at the location
with an on order discrepancy in their inventory) can be used to verify and update each inventory item'’s order
quantities to match the quantities currently on your Purchase Orders.

RECEIVING ITEMS

Whenever you receive items on a Purchase Order Receipt or Transfer, the items will always be added to your stock. If
an item was received for a special order item that was deleted at another location, the quantity will be automatically
added to the stock for the store.

SPECIAL ORDERS

All known issues that can arise in the Batch Process result in incorrect on order quantities for stock or special orders.
Although the on order quantity for an inventory item could be incorrectly reflected in inventory, it will not cause a
special order item requiring ordering or fulfillment to be skipped.

The on order quantities can become incorrect because of the nature of the operations that can be performed on an
individual special order item (i.e. Purchase Orders can be created at a location that does not own the Special Order,
and Purchase Order Receipts can be created at a location that did not create the Special Order or the Purchase
Order). All three items, a Special Order, Purchase Order, and Purchase Order Receipt, affect the on order quantities
for an item, and all three could be created or revised at a different location at the same time. In most cases, the Batch
Process can handle the revisions and will keep all inventory values accurate.

SCENARIOS TO AVOID

Don't delete or revise a Purchase Order on the same day the Purchase Order is received at a remote location.

Try to avoid revising or deleting Purchase Order Receipts with items received for special order items for another
location after the Batch has been run. The special order items could have been delivered before the revisions are
received in the Batch and would result in negative inventory values for the delivered items.

Don't create a Purchase Order Receipt for the same Purchase Order at different locations on the same day.

RECOMMENDATIONS

Don't create Purchase Orders for special order items for a store at more than one location.

Avoid creating Purchase Orders for inventory items below reorder points at more than one location. You could create
a double order if the Purchase Orders are done on the same day.

There is no need to remove an item on a Purchase Order for a Special Order item which was removed from a Special
Order at a remote location. The Batch Process will automatically set the item to an item on order for stock. The item
on the Purchase Order could be revised once the Batch has performed the revision.
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